Domain price error

Minor incident Shopping Cart
2020-03-11 17:33 BST · 2 hours, 28 minutes

Updates

Resolved

Sorry about the delay! We’ve resolved this now.

November 4, 2021 · 15:24 BST
Investigating

We’re aware of an issue where some domain prices are showing incorrectly. We are looking into this.

November 4, 2021 · 15:24 BST

← Back