Website maintenance error

Major incident Shopping Cart Account Login Magic Internet Group Central System
2020-04-26 19:24 BST · 1 hour, 29 minutes

Updates

Resolved

We’ve now implemented a fix.

November 4, 2021 · 15:24 BST
Update

We have identified the issue and our engineers are working on a fix.

November 4, 2021 · 15:24 BST
Issue

We’re aware of an issue where our website is displaying a maintenance error. We are looking into it. Due to this outage, our support staff also can’t access our system so replies to support tickets will he delayed. We apologise for any inconvenience this may cause.

This issue started at 18:21

November 4, 2021 · 15:24 BST

← Back